Jump to content
humildadever

Wireless no BlackArch

Recommended Posts

Fiz um teste em um live do Arc Linux para conectar através terminal e funcionou, neste BlackArch também deve funcionar.

Faça uma configuração de ssid(nome da rede) e password no seguinte diretório /etc/wpa_supplicant/rede.conf após insira a informações da sua rede, conforme exemplo.

 

59bdd5ac36e87_Capturadetelade2017-09-1622-40-18.png.73f57d574f1ce2120c47a02ca376a295.png

 

Trate de validar se a sua interface wifi está up.

ip link set wlp1s0 up  > Subir uma interface

ip link set wlp1s0 down > Desativar uma interface

59bdd690b5738_Capturadetelade2017-09-1622-41-19.png.42f50be53aa399e8d035d53c076c7115.png  

Depois de validar essas a interface do seu computador execute o comandos abaixo para conectar na rede wifi.

wpa_supplicant -B -i wlp1s0 -c /etc/wpa_supplicant/rede.conf

dhclient -v wlp1s0

Testar a conexão e pronto ;)

59bddb022e547_Capturadetelade2017-09-1623-15-57.png.9d0b081aceccebf8e44c5d7703c3ef60.png

 

 


 

  • Like 1

Share this post


Link to post
Share on other sites
22 horas atrás, unamex disse:

Fiz um teste em um live do Arc Linux para conectar através terminal e funcionou, neste BlackArch também deve funcionar.

Faça uma configuração de ssid(nome da rede) e password no seguinte diretório /etc/wpa_supplicant/rede.conf após insira a informações da sua rede, conforme exemplo.

 

59bdd5ac36e87_Capturadetelade2017-09-1622-40-18.png.73f57d574f1ce2120c47a02ca376a295.png

 

Trate de validar se a sua interface wifi está up.

ip link set wlp1s0 up  > Subir uma interface

ip link set wlp1s0 down > Desativar uma interface

59bdd690b5738_Capturadetelade2017-09-1622-41-19.png.42f50be53aa399e8d035d53c076c7115.png  

Depois de validar essas a interface do seu computador execute o comandos abaixo para conectar na rede wifi.

wpa_supplicant -B -i wlp1s0 -c /etc/wpa_supplicant/rede.conf

dhclient -v wlp1s0

Testar a conexão e pronto ;)

59bddb022e547_Capturadetelade2017-09-1623-15-57.png.9d0b081aceccebf8e44c5d7703c3ef60.png

 

 


 

Aparentemente sua interface wireless não foi reconhecida pelo Arc, apareceu algumas mensagens de falha e drive não suportado.

Ontem, segui está documentação para conectar  o notebook na rede wifi, tente refazer novamente. 

 

Share this post


Link to post
Share on other sites

Rfkill caveat

Many laptops have a hardware button (or switch) to turn off wireless card, however, the card can also be blocked by kernel. This can be handled by rfkill. Use rfkill to show the current status:

# rfkill list

0: phy0: Wireless LAN Soft blocked: yes Hard blocked: yes

If the card is hard-blocked, use the hardware button (switch) to unblock it. If the card is not hard-blocked but soft-blocked, use the following command:

# rfkill unblock wifi

 

https://wiki.archlinux.org/index.php/Wireless_network_configuration#Rfkill_caveat

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.